Τετάρτη, 18 Νοεμβρίου 2009

Το ενοχλητικό bug του Firefox 3.5.4The annoying bug of Firefox 3.5.4

Πριν λίγο καιρό ένα φιλαράκι μου, μου είπε πως προσπάθησε να κάνει εγκατάσταση σε ένα plug-in του Firefox. Άνοιξε τα Add-ons, βρήκε το plugin, το κατέβασε και όταν ο Firefox ζήτησε να κάνει επανεκκίνηση στον εαυτό του, ο φίλος πάτησε το "NAI". Ο Firefox έκλεισε, αλλά δεν ξανάνοιξε (όπως θα έπρεπε να κάνει). Ε! λοιπόν, απλά κάνει κλικ στο εικονίδιο, ο Firefox ξανανοίγει, αλλά το plug-in δεν είχε εγκατασταθεί. Ξαναδοκίμασε να το εγκαταστήσει αλλά μια από τα ίδια. Σε κάποια στιγμή το άφησε το θέμα για να κάνει και καμιά άλλη δουλειά. Σε κάποια φάση έκανε μια επανεκκίνηση στον υπολογιστή του και όταν άνοιξε τον Firefox είδε ότι το plug-in είχε εγκατασταθεί κανονικά! 'Ολα αυτά συνέβησαν σε ένα μηχάνημα με Windows.

Όταν μου το είπε φαντάστηκα ότι κάτι θα συμβαίνει με τις processes, αλλά από την άλλη μου φάνηκε λίγο περίεργο...

Some days ago, one friend of mine told me that he tried to install a plug-in in Firefox. He opened the Add-ons, found the plug-in he wanted, he downloaded it and when Firefox asked to restart itself he selected "YES". Firefox just closed and didn't restart (as it should). Well, he clicks on Firefox's icon, Firefox opens up, but the plug-in was not installed! He tried to install it again, but again with the same "success"... At some moment he let go; he wanted to do other things also with his computer. After a while he had to restart his computer and after that when he opened Firefox he saw the plugin was installed successfully! The operating system he usew is Bugindows.

When he told me what happened I imagined that something is wrong with the spawned Firefox processes, but it was a little bit wierd...

Πριν λίγες ημέρες αντιμετώπισα το ίδιο πρόβλημα στο FreeBSD 8.0-RC3. Ένα ps aux |grep firefox με έπεισε ότι είχα δίκιο για τις ξεχασμένες processes. Επίσης, την Κυριακή ξεκίνησα να κάνω εγκατάσταση στο openSUSE 11.2 στο laptop. Σήμερα ήρθε η ώρα να βάλω τα αγαπημένα μου plugins και σε αυτό. Το αποτέλεσμα ήταν το ίδιο. Ο Firefox αφήνει δύο processes ανοικτές με αποτέλεσμα να μη θεωρεί ότι έχει κλείσει καθόλου. Όταν έκανα kill -9 τις διεργασίες αυτές και ξανάνοιξα τον Firefox όλα ήταν ΟΚ. Οπότε έχετέ το στο νου σας μέχρι να φτιαχτεί!

Few days ago I had the same problem in my FreeBSD 8.0-RC3. A ps aux |grep firefox convinced me that I was right about some "forgotten" Firefox processes. Again on Sunday I started to do an installation of openSUSE 11.2 on my laptop. Today was the time to install my Firefox favourite plug-ins. The result was exactly the same; Firefox leaves two of his processes alive. The result is that he feels still active. Executing a kill -9 on these processes, I reopened Firefox and everything was fine. So, keep in mind on this small bug, until the Firefox developers take care of that!


Ώς τότε happy hacking σε όλους.

Until then happy hacking to everybody.

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου